Zhvillimi i aplikacioneve në Flutter

Me Flutter mund të zhvillojmë aplikacione të cilat mund të ekzekutohen në pajisje mobile, kompjuter dhe në Web.

Softueri kryesor që duhet të instalohet është Flutter SDK, ku përfshihen: kompajleri, kreatori i projekteve, menaxhuesi i pajisjeve (device manager), ekzekutuesi i testeve (test runner), dhe mjetet për diagnostifikim.

Flutter SDK shkarkohet si ZIP fajll dhe ekstraktohet në ndonjë lokacion në disk (p.sh. c:\flutter). Më pas e vendosim në PATH lokacionin e zgjedhur.

Prej editorëve, parimisht mund të përdoret cilido editor (p.sh. VS Code, IntelliJ IDEA), por IDE i preferuar është Android Studio.

Për ta përshtatur Android Studion për punë me Flutter, duhet të instalohen DevTools. Zgjedhet File – Settings – Plugins dhe bëjmë kërkim për Flutter, të cilin më pas e instalojmë duke klikuar në butonin Install.

Në VS Code të njëjtën gjë e realizojmë me View – Extensions.

Duke përdorur IDE do të mund ta shkruajmë kodin dhe ta kompajlojmë, por nuk do të mund ta ekzekutojmë. Për ekzekutimin e kodit, na duhet të përdorim emulatorë ose pajisje mobile fizike të lidhur në kompjuter.

Me emulator është lehtë të testohet aplikacioni, sepse nuk nevojitet ta lidhim një pajisje fizike.

Nëse jemi në Windows, do të mund ta testojmë aplikacionin në emulator për Android por jo edhe emulator për iOS.

Ndërsa nëse jemi duke përdorur Mac kompjuter, kemi mundësi të përdorim emulatorë për iOS dhe Android.

Në Android Studio përdorim Tools – AVD Manager për ta instaluar një pajisje mobile virtuale, me ç’rast mund të instalojmë disa pajisje të ndryshme sipas nevojës.

Natyrisht, aplikacionin mund ta testojmë edhe në pajisje mobile fizike, dhe për këtë duhet të aktivizojmë “Developer options” dhe “USB debugging” në pajisjen mobile. Rëndomë këtë e arrijmë duke shtypur 7 herë në “Device Build Number”, ku më pas te “USB Debugging” bëjmë “Enable”.

Për të verifikuar nëse gjithçka është instaluar si duhet, e japim komandën vijuese në terminal:

flutter doctor

Nga raporti i shfaqur shohim se ka vetëm një problem: në IntelliJ IDEA nuk është instaluar plugin-i për Flutter. Natyrisht, ky është problem vetëm nëse atë IDE e përdorim për zhvillim të Flutter aplikacioneve. Problemi evitohet duke e instaluar plugin-in përkatës.

Pasi ta instalojmë dhe ristartojmë, problemi do të largohet, gjë që mund ta vërtetojmë duke e dhënë prapë komandën flutter doctor:

Tash shohim se gjithçka është në rregull.